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SCCalc User Manual 
Professional Statistical Computing for macOS 

Version: 1.0 

Last updated: 2026-05-24 

Copyright 2026 Pengfan Chang. All rights reserved. 

This manual is bundled with SCCalc for offline use and is also published online. It is written for 
researchers, students, analysts, and instructors who need a reliable desktop workflow for 
preparing data, running analyses, reviewing results, exporting reports, and automating 
repeatable work with SCL. 

Use it as a task guide. It explains the normal path through a project, the checks to run before 
interpreting output, and the safest way to prepare support examples without exposing 
confidential data. For command syntax and detailed procedure references, use the in-app SCL 
Quick Reference and the online Command Reference from the Help menu. 
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Getting Started 

What SCCalc Does 
SCCalc is a native macOS statistical computing app for desktop analysis work. It combines a 
spreadsheet-style data editor, variable metadata, guided analysis dialogs, a results workspace, 
and SCL automation in one project-oriented app. 
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The built-in procedures run directly on your Mac. You do not need to install R, Python, or a 
separate statistics runtime for supported analyses. 

Use SCCalc when you need to: 

- Import or create tabular research, teaching, business, or survey data. 

- Review variable names, labels, types, measurement levels, and missing values. 

- Run common statistical procedures from guided dialogs. 

- Inspect warnings, tables, charts, and model summaries before reporting. 

- Export results for review, publication, teaching, or archiving. 

- Repeat a workflow with SCL scripts after data or options change. 

System Requirements 
- macOS 26.0 or later. 

- Apple Silicon Mac. 

- 8 GB RAM minimum, with 16 GB recommended for larger datasets. 

- Sufficient free disk space for project files, exports, and temporary reports. 

- Network access only when you want online help, support pages, or published 

documentation. The bundled manual and built-in analysis workflows are available offline. 

First Launch 
1. Open SCCalc from Applications. 

2. Create a new project or open an existing project. 

3. Import a CSV file, open sample data, generate a practice dataset, or paste 

tabular values into the data editor. 

4. Review the sheet in Data Editor and switch to Variable View to check 

metadata before running inferential procedures. 

5. Run an analysis from the Analysis menu. 

6. Inspect the output in Results, including warnings and notes. 

7. Export the result only after confirming it contains the intended data and no 

confidential information. 

Recommended First Workflow 



SCCalc User Manual

Page 3

Start with sample data before using private or high-value files. A simple first run verifies file 
access, result rendering, and export permissions. 

1. Choose File -> Open Sample Data. 

2. Pick a small sample dataset. 

3. Choose View -> Variable View and confirm the variable names and measurement 

levels look reasonable. 

4. Choose Analysis -> Descriptive Statistics -> Descriptives. 

5. Select a few numeric variables and run the procedure. 

6. In Results, read the table from top to bottom and check whether any warnings 

were added. 

7. Choose Results -> Export Results -> Export as PDF. 

8. Open the exported PDF and confirm the tables, labels, and file destination 

are correct. 

After this succeeds, repeat the same path with your own data. If something fails with your data 
but not with sample data, the issue is usually related to file encoding, variable metadata, 
missing values, unusual labels, or the analysis options selected for that dataset. 

Project Workflow Map 
Most projects follow this sequence: 

Data source -> Data Editor -> Variable View -> Data checks -> 

Analysis dialog -> Results -> Export, save, or automate with SCL 

Move forward only when the current step is clean enough for the next step. For example, do not 
run a model until numeric variables imported as numbers, group variables have the expected 
categories, and missing-data handling is understood. 

Offline And Online Help 
The Help menu separates offline and online resources: 

- Help -> User Manual opens the offline PDF bundled with the app. 

- Help -> User Manual Online opens the latest published online manual. 

- Help -> SCCalc Help opens the searchable in-app help center. 

- Help -> Tutorials opens guided lessons and sample workflows. 
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- Help -> Keyboard Shortcuts opens shortcut reference material. 

- Help -> SCL Quick Reference opens command syntax help for automation. 

- Help -> Command Reference opens the online command and analysis reference 

when network access is available. 

- Help -> Support opens current support information. 

When working without a network connection, prefer the bundled manual, in-app help center, 
tutorials, sample data, and SCL Quick Reference. When network access is available, use the 
online manual for the latest published corrections and support links. 

Privacy Check 
Before copying, exporting, or sharing anything, pause and check whether the current view 
contains confidential information. Data values, variable labels, file paths, comments, output 
titles, charts, and screenshots can all reveal more than intended. 

If you need help reproducing an issue, start with sample data. If the issue only appears in your 
own dataset, create a small synthetic file with the same column types and missing-data pattern 
instead of sending real participant, customer, student, patient, financial, institutional, or 
unpublished research data. 

Workspace Basics 

Main Areas 
SCCalc is organized around stable work areas: 

- Data Editor: enter, paste, inspect, edit, sort, and review rows and columns. 

- Variable View: review names, labels, types, measurement levels, value labels, 

and missing-value conventions. 

- Analysis dialogs: select variables, set procedure options, and run analyses. 

- Results: inspect tables, charts, model summaries, warnings, and export-ready 

output. 

- SCL tools: write, run, debug, and reuse repeatable analysis workflows. 

- Help: search task help, tutorials, shortcuts, support guidance, and manuals. 

The menu bar is the primary command surface. Toolbar controls and contextual panes support 
common tasks, but the menus give the most complete view of what the app can do. 
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Projects And Files 
Project files keep the working dataset, metadata, notes, and analysis context together. Use File 
-> New Project, File -> Open Project, File -> Save Project, and File -> Save Project As for 
project-level work. 

Because SCCalc is sandboxed on macOS, file access is granted through system open and save 
panels. When importing, saving, or exporting, choose the file or destination folder through the 
macOS panel so SCCalc receives permission to read or write there. 

Use File -> Duplicate Project before risky restructuring, large transformations, or exploratory 
analysis. A duplicate gives you a clean recovery point without changing the original project. 

Data And Variable Views 
Use Data Editor for row-and-column inspection. It is the best place to spot empty rows, obvious 
typing errors, unexpected category labels, outliers, and columns that imported as text. 

Use Variable View before inferential analysis. Confirm: 

- Variable names are unique and stable. 

- Labels describe the construct without exposing private context. 

- Numeric variables imported as numeric values. 

- Categorical variables have the expected categories. 

- Measurement levels match the procedure you plan to run. 

- Missing-value conventions are documented. 

If analysis dialogs reject a variable or produce unexpected warnings, return to Variable View 
and check type, measurement level, and missing-data settings first. 

Navigation 
Use these menus for the main workflow: 

- File: project creation, opening, saving, import, export, printing, and file 

security. 

- View: zoom, toolbar and inspector visibility, spreadsheet and variable views, 

formula bar, sheet tabs, status bar, and freeze panes. 

- Data: variable properties, named ranges, generated datasets, sorting, 

restructuring, merging, aggregation, filtering, weighting, transformations, cleaning, validation, 
and exploration. 
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- Analysis: statistical procedure families, workflow builder, and Run Again. 

- Results: results browser, reports, diagrams, display options, result export, 

output documents, pinned results, and verification. 

- SCL: SCL IDE, scripts, highlighted code export, script execution, navigator, 

debug area, inspector, command palette, snippets, and SCL shortcuts. 

- Help: manuals, tutorials, keyboard shortcuts, SCL references, sample data, 

feedback, support, community links, and privacy policy. 

Working Safely 
Before major transformations, save the project. For work that must be auditable, keep an 
unchanged copy of the original source data in a secure location outside the working project. 
Record any transformation choices that affect results, including filters, computed variables, 
reverse-coded items, weighting, split files, imputation, and deleted cases. 

For analysis sessions that may be repeated, move the workflow into an SCL script once the 
manual dialog steps are stable. A script makes it easier to re-run the same import, preparation, 
analysis, and export steps after new data arrives. 

Confidential Workspaces 
Treat the workspace as confidential whenever it contains real participant, customer, student, 
patient, financial, institutional, proprietary, or unpublished research data. Before sharing 
screenshots, project files, SCL scripts, or exported output, remove: 

- Names, IDs, email addresses, account numbers, and direct identifiers. 

- Rare categories, locations, timestamps, and other indirect identifiers. 

- Raw free-text responses, comments, and notes. 

- Private file paths, organization names, project names, and unpublished study 

labels. 

- Passwords, tokens, secrets, and internal service URLs. 

- Results that are not approved for disclosure. 

If you are unsure whether something is confidential, do not share it. Describe the workflow and 
error first, then prepare a sample or synthetic reproduction if support needs more detail. 

Data Import And Preparation 
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Supported Data Entry Paths 
SCCalc supports common desktop analysis workflows: 

- Import CSV data through File -> Import Data. 

- Open built-in sample datasets through File -> Open Sample Data. 

- Generate practice data through Data -> Generate Random Dataset. 

- Create an empty CSV through Data -> Create Empty CSV. 

- Paste tabular values into the data editor. 

- Use SCL commands for repeatable import and preparation workflows. 

For support, teaching, and first-run verification, sample data is usually the safest starting point. 
For real research or operational work, keep the original source file unchanged and work from an 
imported project copy. 

CSV Import Checklist 
CSV is the primary interchange format. For best results: 

1. Export the source data as UTF-8 CSV. 

2. Keep the first row as column names when possible. 

3. Use one consistent delimiter throughout the file. 

4. Avoid merged headers, titles, subtotal rows, footnotes, and report-style 

formatting. 

5. Remove blank trailing rows and columns if the source system adds them. 

6. Prefer one observation per row and one variable per column. 

7. Review inferred variable types immediately after import. 

If characters appear garbled, convert the source file to UTF-8 and import it again. SCCalc 
attempts common legacy encodings, but UTF-8 is the most reliable path for multilingual data. 

Variable Metadata 
After import, open Variable View and check: 

- Variable names are unique, meaningful, and stable enough to reference in SCL. 

- Labels describe survey items or measured constructs. 

- Measurement levels match analysis requirements. 

- Missing-value conventions are documented. 

- Numeric variables imported as numeric values, not text. 
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- Categorical variables have expected labels and category counts. 

Use neutral names and labels when you plan to share examples outside your team. Remove 
names, IDs, account numbers, email addresses, locations, free-text comments, and other direct 
or indirect identifiers before creating support examples. 

Data Management Tools 
The Data menu contains preparation tools that usually happen before analysis: 

- Define Variable Properties for names, labels, types, and metadata. 

- Named Ranges for reusable groups of cells or variables. 

- Sort Cases for review and ordered workflows. 

- Restructure -> Transpose, Pivot Wider, and Pivot Longer for reshaping data. 

- Merge Files -> Add Cases or Add Variables for combining compatible data. 

- Aggregate for summarized datasets. 

- Split File, Select Cases, and Weight Cases for scoped analysis. 

- Transform -> Transform Variables, Compute Variable, and Create Scale for 

derived variables and survey scales. 

- Data Cleaning -> Clean Data and Identify Duplicates for quality review. 

- Validate Data for a structured validation summary. 

- Data Exploration -> Explore Data and Statistical Dashboard for preliminary 

inspection. 

Run these tools intentionally. A filter, split, weight, or transformation can change every analysis 
that follows. Save the project or duplicate it before large changes. 

Missing Data 
Inspect missing data before analysis. Different procedures may use listwise deletion, pairwise 
deletion, imputation, or procedure-specific handling. Record the choice in your notes, SCL 
script, or project documentation so exported output can be interpreted later. 

Before choosing an approach, check: 

- Whether missingness is expected by design. 

- Whether missing values use one convention or several conventions. 

- Whether placeholder values such as 999, -99, or "N/A" imported as real data. 

- Whether missingness differs by group, time, site, or condition. 
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- Whether the planned procedure reports omitted cases or warnings. 

Data Quality Checks 
Before inferential analysis, check for: 

- Outliers and impossible values. 

- Miscoded categories. 

- Unexpected text in numeric columns. 

- Duplicated identifiers. 

- Empty or constant variables. 

- Reverse-coded items that have not been reversed. 

- Scale items with inconsistent direction. 

- Date or time fields imported as plain text. 

- Labels that reveal confidential study or organizational context. 

Use Data -> Validate Data and Data -> Data Exploration for broad review, then inspect 
suspicious variables directly in Data Editor and Variable View. 

Preparing Shareable Examples 
When you need to demonstrate an issue, start with SCCalc sample data whenever possible. If 
the issue only appears in your own dataset, create a small synthetic file with the same shape: 

- The same number of relevant columns. 

- Similar variable types and measurement levels. 

- The same kind of missing-data pattern. 

- Similar category labels, but neutral names. 

- Enough rows to reproduce the issue, not the whole original dataset. 

Do not include real names, IDs, raw responses, confidential categories, private comments, 
secrets, passwords, tokens, private file paths, or unreleased results in files shared for support. 

Running Analyses 

General Analysis Workflow 
Most guided procedures follow the same pattern: 
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1. Confirm the dataset, filters, split files, weights, and missing-data settings. 

2. Open an analysis from the Analysis menu. 

3. Select dependent, independent, grouping, time, panel, or model variables as 

required by the procedure. 

4. Configure options such as confidence levels, model terms, bootstrap settings, 

missing-data handling, diagnostics, plots, and output details. 

5. Run the procedure. 

6. Review warnings, assumptions, omitted cases, tables, charts, and model 

summaries in Results. 

7. Export only the output needed for reporting, review, or archiving. 

For confidential projects, confirm that selected variables, labels, output titles, charts, and 
exported filenames do not expose private identifiers before sharing results. 

Choosing Variables 
SCCalc uses variable metadata to guide setup, but you should still confirm every role. For 
example: 

- Grouping variables should be categorical and contain the intended groups. 

- Scale variables should be numeric and measured at an appropriate level. 

- Time-series variables should be ordered consistently. 

- Panel identifiers should uniquely identify entities. 

- Model terms should match the research design, not only the column names. 

- Weight and filter settings should be intentional and documented. 

If a dialog does not offer the variable you expected, check Variable View for type, measurement 
level, and missing-value metadata. 

Procedure Families 
The Analysis menu groups procedures by use case. Use the family names to orient your choice, 
then rely on the procedure dialog, SCL Quick Reference, and Command Reference for detailed 
syntax and options. 

- Descriptive Statistics: summaries, frequencies, crosstabs, chi-square tests, 

Q-Q plots, and multiple response summaries. 

- Correlation & Regression: correlations, partial correlations, distance 
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correlation, linear regression, linear models, curve estimation, and related model families. 

- Compare Means: t tests, ANOVA, GLM univariate workflows, and common 

nonparametric alternatives. 

- General Linear Model and Generalized Linear Models: univariate, multivariate, 

repeated measures, logistic, ordinal, probit, and multinomial workflows. 

- Mixed Models: linear mixed models, generalized linear mixed models, and 

generalized estimating equations. 

- Dimension Reduction and Scale: factor analysis, principal components, 

optimal scaling, proximity mapping, and reliability analysis. 

- Classify, Cluster, and Market Research: discriminant analysis, nearest 

neighbor, decision trees, neural networks, ROC curves, clustering, conjoint, and 
multidimensional unfolding. 

- Mediation & Moderation: mediation, moderation, parallel mediation, moderated 

mediation, and cross-lagged panel workflows. 

- Time Series, Panel Data, Forecasting, and Survival: ordered data, panel 

effects, stationarity and volatility workflows, forecasts, and survival models. 

- Bayesian, SEM, Utilities, Geospatial, and Meta-Analysis: specialized 

procedure groups where enabled. 

This manual does not replace a statistical methods text. It explains how to use SCCalc safely 
and reproducibly. Choose methods based on your design, data collection process, 
assumptions, and reporting requirements. 

Assumptions And Warnings 
Treat warnings as part of the analysis result. Review: 

- Sample size and omitted cases. 

- Missingness and filtering. 

- Constant or near-constant variables. 

- Singular matrices and collinearity. 

- Convergence messages. 

- Model-fit diagnostics. 

- Distributional or residual assumptions. 
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- Category counts and sparse cells. 

- Warnings about unsupported options or fallback behavior. 

Do not copy a coefficient, p value, fit index, or chart into a report until you understand any 
warning that appears near it. If a result looks wrong, return to the data and metadata before 
changing model options. 

Run Again And Workflow Builder 
After a successful procedure, use Analysis -> Run Again to repeat the last analysis when the 
same setup is still appropriate. Use Analysis -> Analysis Workflow when you need a more 
structured multi-step workflow. 

For work that must be repeated across datasets or over time, convert the stable steps into SCL. 
Manual dialog setup is useful for discovery; SCL is better for review, repetition, and audit trails. 

Reproducibility 
For every analysis you may need to defend or rerun, record: 

- Source data and import date. 

- Variable transformations and scale construction. 

- Filters, split files, and weights. 

- Procedure name and selected variables. 

- Missing-data handling. 

- Confidence levels, bootstrap settings, and model options. 

- Export format and output filename. 

- Any warnings that affect interpretation. 

If an SCL script will be shared, review it for private file paths, dataset names, comments, 
embedded values, passwords, tokens, and organization-specific labels. Replace those details 
with neutral placeholders before sending the script outside your trusted team. 

Results And Exporting 

Reviewing Output 
Results can include tables, model summaries, charts, warnings, diagnostics, notes, and export-
ready reports. Review output from top to bottom before copying individual values. 
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Check whether the result includes: 

- Omitted cases or filtered rows. 

- Missing-data decisions. 

- Warnings about assumptions, convergence, sparse cells, or singular matrices. 

- Procedure options that differ from your intended setup. 

- Variable labels, row labels, titles, or filenames that expose private context. 

- Charts or footnotes that need explanation before sharing. 

When results look surprising, return to the dataset and metadata first. Many unexpected 
outputs come from imported text columns, miscoded categories, active filters, split files, 
weights, missing-value conventions, or stale assumptions about the data. 

Results Browser 
Use Results -> Results Browser to review completed analyses. Keep related outputs together 
when preparing a report, and remove or ignore exploratory results that should not be included 
in final documentation. 

Use Results -> Display Options when the same output needs different presentation settings for 
review, teaching, or publication. Use pinned results when you need to compare selected 
outputs, and clear pins when the comparison is no longer needed. 

Export Formats 
Choose export formats based on the destination: 

- PDF for archival reports, printing, and sharing with reviewers. 

- HTML for browser-readable output and internal review. 

- LaTeX for manuscript workflows that use TeX. 

- Word or OpenDocument for editable report handoff. 

- Markdown or text for lightweight version-controlled notes. 

- CSV or spreadsheet formats when downstream tools need table data. 

- Image or vector formats for charts when publication graphics are required. 

- SCCalc output documents when you need to reopen output later in the app. 

Before sending any exported file outside your trusted team, open it and confirm that no 
confidential data, identifiers, private comments, passwords, tokens, private paths, or 
unapproved results are included. 
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Publication Workflow 
For final reports: 

1. Reopen or save the current project. 

2. Confirm filters, split files, weights, and variable metadata. 

3. Re-run the analysis from saved data or a saved SCL workflow. 

4. Confirm the output timestamp, procedure options, and dataset state. 

5. Read all warnings and notes. 

6. Export a PDF report for archival use. 

7. Export tables or charts separately if a journal, reviewer, collaborator, or 

teaching workflow requires a different format. 

8. Review each exported file for confidential data before distribution. 

Verification 
Use Results -> Verify Results when you want a structured check of exported or generated 
output. Copy the verify log when support or a collaborator needs to understand which outputs 
were checked. 

Verification does not replace statistical judgment. It helps confirm that outputs are present and 
internally consistent enough to review. You are still responsible for method choice, 
interpretation, disclosure review, and any domain-specific reporting requirements. 

File Access 
When exporting, choose the target folder from the macOS save panel. If an export fails with a 
permission message, repeat the export and explicitly select the destination folder in the system 
panel. Avoid moving or renaming destination folders while an export is in progress. 

If an exported file appears incomplete, close preview or editor apps that may be holding the file 
open, then export again to a new filename. 

SCL Automation 

What SCL Is 
SCL is SCCalc's command language for repeatable statistical workflows. It is designed to make 
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common analysis steps scriptable, reviewable, and easier to rerun after data changes. 

Use guided dialogs to discover the right setup. Use SCL when the setup becomes part of a 
workflow that should be repeated, reviewed, taught, or archived. 

When To Use SCL 
Use SCL when: 

- The same analysis must be run on multiple datasets. 

- You need a reproducible record of import, transformation, and analysis steps. 

- A workflow is too repetitive for manual dialog configuration. 

- You want to share a compact analysis recipe with collaborators. 

- You need to rerun a project after a new data extract arrives. 

- You want exported reports to follow a predictable naming pattern. 

SCL IDE 
Use SCL -> Open SCL IDE to open the scripting workspace. The SCL menu also lets you create, 
open, save, run, and stop scripts; run a selected block; show the command palette; insert 
snippets; and open SCL keyboard shortcuts. 

Useful commands while editing: 

- SCL -> Run Script runs the active script. 

- SCL -> Run Selection runs selected commands. 

- SCL -> Stop stops the current execution when available. 

- SCL -> Command Palette helps find commands. 

- SCL -> Insert Snippet opens reusable examples. 

- Help -> SCL Quick Reference opens syntax help. 

- Help -> Command Reference opens the online command and analysis reference 

when network access is available. 

Typical Script Flow 
An SCL workflow usually follows this shape: 

1. Import or reference a dataset. 

2. Define variables, filters, transformations, labels, or scales. 

3. Run one or more analysis commands. 
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4. Export results in a stable format such as PDF, HTML, Markdown, CSV, or JSON. 

5. Save the script with the project or in version control if the workflow needs 

review. 

Example outline: 

* Import data or open an existing project. 

* Review and prepare variables. 

* Run the planned analysis. 

* Export a report and verification output. 

Use the exact syntax shown by the SCL Quick Reference and Command Reference for real 
scripts. This manual describes workflow shape rather than full command grammar. 

Good Script Practices 
- Keep one logical workflow per script. 

- Use descriptive file names and comments. 

- Prefer explicit variable names over positional assumptions. 

- Keep import paths and export paths easy to review. 

- Save exported outputs with dates or project identifiers when appropriate. 

- Re-run scripts after data edits to verify reproducibility. 

- Keep a short note explaining the dataset, purpose, and expected outputs. 

- Use sample or synthetic data when sharing a script for support. 

Sharing Scripts Safely 
SCL scripts can reveal more than commands. They may include private file paths, dataset 
names, variable labels, comments, filters, embedded values, export locations, organization 
names, or research context. 

Before sharing a script: 

1. Replace sensitive paths with neutral placeholders. 

2. Remove secrets, passwords, tokens, and private comments. 

3. Rename confidential variables and labels. 

4. Use sample or synthetic data. 

5. Test the sanitized version before sending it. 
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Do not send a script that references confidential files unless the recipient is authorized to know 
those paths and contents. 

Automation And Results 
When SCL is used for reporting, include verification steps in the workflow where possible. A 
reproducible analysis should be able to answer four questions: 

- Which data was used? 

- Which transformations and options were applied? 

- Which outputs were produced? 

- Were warnings or verification messages reviewed? 

Keep exported reports and scripts together when archiving a project. If a result changes after 
rerunning the script, compare data changes, option changes, and warnings before interpreting 
the difference. 

Troubleshooting 

Start With A Small Reproduction 
When something does not work as expected, first try to reproduce it with the smallest safe 
example: 

1. Save the project. 

2. Try the same action again. 

3. Try the workflow with built-in sample data. 

4. If the issue only appears in your data, make a small synthetic dataset with 

the same column types and missing-data pattern. 

5. Record the exact menu path, selected variables, options, warnings, and error 

message. 

This approach separates app behavior from dataset-specific problems and makes support 
requests safer. 

Import Problems 
If a file does not import correctly: 
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- Confirm the file is a plain CSV when using CSV import. 

- Check whether the first row contains column names. 

- Convert legacy encodings to UTF-8. 

- Remove report titles, footnotes, merged cells, blank trailing columns, or 

subtotal rows. 

- Open the file in a text editor to confirm delimiters are consistent. 

- Check whether decimal separators, dates, or quoted text use a format SCCalc 

can infer reliably. 

After import, immediately review Data Editor and Variable View. Most import problems are 
easier to fix before transformations and analyses have been run. 

Permission Errors 
SCCalc is sandboxed. If opening, saving, or exporting fails: 

1. Retry the operation. 

2. Select the file or destination folder through the macOS open or save panel. 

3. Avoid moving project files while SCCalc is open. 

4. Save a new copy if the original location no longer grants access. 

5. Export to Documents or Desktop to test whether the issue is folder-specific. 

Do not edit app bundle contents or generated manual files directly. Use normal project, import, 
and export commands so macOS can manage permissions. 

Unexpected Analysis Output 
If results look wrong: 

- Confirm variables have the expected measurement levels and numeric types. 

- Check missing data and filtering choices. 

- Check whether split file or weighting is active. 

- Inspect outliers and impossible values. 

- Verify grouping variables contain the intended categories. 

- Confirm reverse-coded items and scales were prepared correctly. 

- Re-run the analysis from saved data to confirm the result is reproducible. 

If the same procedure works with sample data but not your dataset, inspect the specific 
variables used by the procedure. Look for imported text, sparse groups, empty variables, 
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invalid values, and labels that differ by spelling or case. 

Export Issues 
If a PDF, chart, table, or report export fails: 

- Choose a different folder such as Documents or Desktop through the save panel. 

- Use a new filename. 

- Close preview apps that may be holding the file open. 

- Confirm there is enough disk space. 

- Export a smaller result or a different format to isolate the issue. 

Before sharing a failed export for review, open the file and remove or recreate any confidential 
data, labels, comments, paths, or results. If the file cannot be sanitized, describe the issue 
using sample data instead. 

Online Help Not Available 
If online resources do not open: 

- Confirm the Mac has network access. 

- Use Help -> User Manual for the bundled offline PDF. 

- Use Help -> SCCalc Help for the in-app help center. 

- Use Help -> SCL Quick Reference for local command syntax guidance. 

- Try the online manual later if the issue appears to be network-related. 

The offline manual may not include the newest website corrections, but it is the best source 
when working without a network connection. 

When To Contact Support 
Contact support when a workflow fails repeatedly with the same data and options or when a 
result cannot be explained by data, metadata, filters, weights, or procedure settings. 

Include: 

- SCCalc version. 

- macOS version. 

- Import format and approximate dataset size. 

- Analysis procedure and selected options. 

- Any warnings shown in Results. 
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- Whether the same issue appears with sample data. 

- A sanitized or synthetic reproduction when possible. 

Do not send raw confidential data, unredacted project files, private screenshots, passwords, 
tokens, or secrets. If support needs an example, provide sample data or a small synthetic 
dataset that reproduces the issue without exposing real people, organizations, research 
subjects, customers, or unpublished results. 

Support And Reference 
Use this chapter when you need help resources, support expectations, diagnostic details, or 
guidance for sharing safe examples. 

In-App Resources 
Use these Help menu resources first: 

- Help -> SCCalc Help: searchable task-focused help center. 

- Help -> User Manual: this offline PDF manual. 

- Help -> User Manual Online: latest published manual when network access is 

available. 

- Help -> Tutorials: guided lessons and sample workflows. 

- Help -> Keyboard Shortcuts: shortcut reference. 

- Help -> SCL Quick Reference: command syntax reference. 

- Help -> Command Reference: online command and analysis reference. 

- Help -> Sample Data Files: bundled datasets for learning and verification. 

- Help -> Send Feedback: send product feedback. 

- Help -> Support: current support information. 

- Help -> Contact Support: open an email support flow when available. 

Online Resources 
When network access is available, use the online manual for the latest published corrections 
and chapter links. Use the support page for current contact information, troubleshooting 
expectations, privacy guidance, and product links. 

If the online manual and the bundled offline manual differ, treat the online manual as the newer 
published text and the bundled PDF as the version that shipped with your installed app. 
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Diagnostics 
When reporting an issue, include enough information to reproduce it: 

- SCCalc version. 

- macOS version. 

- Import format and approximate dataset size. 

- Whether the data came from CSV, sample data, pasted values, generated data, or 

an SCL workflow. 

- The menu path or SCL command used. 

- Analysis procedure and selected options. 

- Any warnings shown in Results. 

- Whether the same issue appears with sample data. 

- Whether filters, split files, weights, or missing-data settings were active. 

Keep the report short and factual. The best report usually states what you expected, what 
happened instead, and the smallest safe reproduction you can provide. 

Protecting Confidential Information 
Do not include raw confidential data, full project files, unredacted screenshots, private file 
paths, passwords, tokens, secrets, or identifying information in support requests. Use one of 
these safer options instead: 

- Reproduce the issue with SCCalc sample data. 

- Create a small synthetic dataset with the same column types and missing-data 

pattern. 

- Describe the workflow, selected options, and error message without including 

real values. 

- Crop or redact screenshots so names, IDs, values, notes, and file paths are 

not visible. 

- Replace organization, study, course, site, and participant labels with 

neutral placeholders. 

If you are unsure whether something is confidential, do not send it. Describe the issue first and 
wait for guidance. 
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Manual Updates 
The offline PDF manual is bundled with SCCalc and refreshed during app development. The 
online manual is generated from the same source and can be updated between app releases. 
Do not edit generated PDFs or website chapter files directly; update the manual source and 
regenerate the outputs. 

Copyright Notice 
This user manual is provided for use with SCCalc. Distribution is permitted when distributed 
with the SCCalc application or with explicit permission from the copyright holder. Unauthorized 
modification or redistribution outside those terms is prohibited. 


